As we all know that the new update of iOS 5 which is iOS 5.1 is coming soon. Apple has released iOS 5.1 Beta 1 for Developers few weeks back. With the update of iOS 5.0.1 from iOS 5.0, we never had a chance to save our SHSH Blobs for iOS 5.0. There was no way till now by which we could even save the SHSH Blobs for iOS 5.0.1. It was looking like every one had given up and now the dog and cat fight is over. We only had two options, Either to stay on iOS 5.0 or compromise with Jailbreak and update to iOS 5.0.1 o fix the battery issues.

Many of you might have updated to iOS 5.0.1 and some of you might be still one iOS 5.0. Those of who you updated to iOS 5.0.1 to fix the battery issues, later on found out that the issue is still present. After finding and swearing at Apple, there was no way you can go back to iOS 5.0. Later on Tiny Umbrella Developer, NotCom, made a move and updated its tool to save Tentative SHSH blobs for iOS 5.0.1 and iOS 5.1 Beta 1. This update brought us some hope. Later on, after the update of Tiny Umbrella, ih8sn0w, the well known hacker behind the tool Sn0wbreeze, made an update to its tool called iFaith.

iFaith is the tool made by ih8sn0w to dump your current SHSH blobs. After the update of iFaith, to save the SHSH Blobs for iOS 5.0 and iOS 5.0.1, we were happy now. Those who were on iOS 5.0 saved their SHSH for iOS 5.0 and those who were one iOS 5.0.1 saved their iOS 5.0.1 SHSH blobs. With those SHSH Blobs you can restore to the firmware you are on. Somehow this wasn’t a perfect solution for people who want to downgrade. They could only downgrade to the firmware they are on. But this iFaith update didn’t made us lose our hope.

More over the idea of iFaith and the AP Tickets saving impressed the Dev-Team. So today the Dev-Team announced that they are working on a new version of Redsn0w which will help people to go back on older version of iOS 5. The new version Redsn0w will make the use of both Cydia and Tiny Umbrella SHSH Blobs.

Today @MuscleNerd Tweeted that:

Upcoming redsn0w release makes both TinyUmbrella and Cydia blob saves useful for 5.0+ (1st verifies, then stitches)

This is a great news for all the down-graders waiting for some perfect solution.

@MuscleNerd also Tweeted that people should save the SHSH Blobs for iOS 5.0.1 as for now using the current version of tiny Umbrella.

For time being, please just use most recent TU to save 5.0.1 blobs+APTicket…redsn0w will do the rest, should you need to restore.

This is another great news and a new hhope for all of us by the Dev-Team.

But the question is, do we really need a Downgrade?

Most you would answer, YES. But in my opinion NO!. Because the most important thing we need is Jailbreak and Unlock. And no one is talking about it.