Today the Dev-Team released Redsn0w 0.9.9b9b with the support of iOS 5.0.1. In the previous release of Redsn0w, we had to choose iOS 5.0 in order to Jailbreak iOS 5.0.1. After choosing iOS 5.0 to Jailbreak iOS 5.0.1, we use to face some issues which are now solved in this new build. When ever there is a new release of iOS, the old basebands which are Unlock-able and depend upon Ultrasn0w, require a fix for Ultrasn0w to work on old basebands. Most of you are on iOS 5.0 or iOS 5.0.1 with old baseband and waiting for the Ultrasn0w to work on it. You migh have cam across many fix for Ultrasn0w, but out of them hardly very little method works and by the end of the day, you are downgrading the iOS to the one on which Ultrasn0w works.

So, with the release of Redsn0w 0.9.9b9, @MusclNerd also said in the change log that the support for old basebands of Ultrasn0w will be made by next Monday.

ultrasn0w compatability update (i.e. same baseband requirements) for 5.0.1 will be available on Cydia Monday

The Ultrasn0w will be updated to 1.2.5 to support all the previous basebands which are:

  • 1.59.00
  • 5.13.01
  • 5.12.01
  • 6.15.00

RunningĀ  iOS 5.0.1. The next update will not include any new Unlock for the new basebands. So don’t think the update as a new Unlock for any new baseband. The new update of Ultrasn0w will be a fix for old basebands.