In our last post we reported that:

Ultrasn0w fixer will unlock iPhone 4 basebands of, iOS 4.1, iOS 4.2.1 and the latest one iOS 4.3 which have these basebands (4.10.01 / 3.10.01 / 2.10.04).

Although this is news is not correct and we are sorry for giving out the wrong news, it was misunderstood due to ih8sn0w Tweets and some blogs are also claiming the same thing

Will ultrasn0w fixer work on iPhone 4 ?
According to iH8sn0w you will be able to unlock iPhone 4 on iOS 4.3 / 4.2.1 / 4.1 basebands 4.10.01 / 3.10.01 / 2.10.04 with the ultrasn0w fixer soon.

The above statement is also from a blog claiming the same thing. Don’t believe in this thing as it is fake. What ih8sn0w Tweeted was:

What he meant here was, the ultrasn0w on iOS4.3 is currently broken for all the users and he got the fix ready and is onto some testing. He meant by iPhone4 was that, it is for those who got the Baseband 1.59.04 and willing to update to iOS4.3 using Sn0wbreeze while preserving their baseband will be able to Unlock soon when the Ultrasn0w is fixed. It will be fixed to work on iPhone3GS,iPhone4 on basebands <6.15.00,and 1.59.04 of iPhone4. It will not provide any new baseband Unlock. The Unlock work is of Sherif_Hashim.

This thing was also confirmed by ih8sn0w on iRC that this won’t do any new unlock. So don’t get scammed.

I personally confirmed from them and the Fixer will just make the Ultrasn0w work on iOS4.3 that’s it. They never said about Updating ultrasn0w to 1.3. About the official Unlock Statement it will be coming out when it is ready, the ETA by us is a month or so.