Just right after performing the iOS 5 / 5.0.1 Untethered jailbreak on the A4 devices users start complaining that they are no more able to use the iBooks on their devices, and need an urgent fix for the problem on the latest jailbreak. In the past we have seen similar issues with jailbreak and iBooks compatibility, as the Apple has baked their iBooks not to work on the jailbroken device. Every time new jailbreak comes, the mega mind behind the jailbreak exploit needs to fix the iBooks issue with another exploit to make it work on the jailbroken iOS. So similar to the past cases, this time again iBooks stop working on the iOS 5 / 5.0.1 untethered jailbreak devices, and hackers start receiving rude words from the normal users to fix the iBooks on their devices.

However, the jailbreak hackers have already started their work on iBooks compatibility and hold the new updates of their softwares till they not able to run iBooks on new untethered jailbreak. Well, it appears that a little work around was already present in the sea of tweaks, which enable the iBooks to work again on the iOS 5 / 5.0.1 untethered jailbreak.

Most of the iBooks reader on iOS 5 / 5.0.1 Untethered jailbreak is facing “Configuration Error” in the latest iBooks right now on the jailbroken devices, and many of them have already restore their devices to the stock version until the fix won’t come out! Well, now you not need to wait anymore, because as we have stated above in the post, the fix is already present in the Cydia.

There is a tweak present on the Insanely Repo with name of “iBooksFix2” to fix the iBooks issues on the latest iOS 5 / 5.0.1 Untethered jailbreak, so simply download the tweak and install it on your device to fix the issue. After installing the tweak, you might able to run iBooks on your device without any problem. If it crashes on your device, simply reboot your device and again launch the application.


we have tested the tweak work with Corona Untethered Jailbreak, and it works good for us. but some users have reported that this tweak is not compatible with new RedSn0w jailbreak update, so if you are one of those who have jailbreaked their devices completely from scrap, avoid this tool until the fix not come up.